Share Your Work - Assignment 3

I still unable to get the dataset_url from kaggel

Hi, Aakashns,

Using Kaggle, I could not download the dataset at all, I don’t know how to go around this step
dataset = CIFAR10(root=‘data/’, download=True, transform=ToTensor())
test_dataset = CIFAR10(root=‘data/’, train=False, transform=ToTensor())

They failed again and again.

tao

Here’s the link to my work!
https://jovian.ml/akashravichandran/03-cifar10-feedforward

Finally, by linking google account to Kaggle and add the cloudstorage and ml functions, the code works now.
Thanks,
tao

Hi,

Find my notebook
Coudn’t get past 56% accuracy.
Will try tuning more.

Any suggestions?

1 Like

A post was merged into an existing topic: Share your work : June 1 - June 7

Hi guys, check out my assignment:
cifar-neuralnet-final.

I have tried with to create two models with different architectures, the first one gives an accuracy of appx 40% and second model with 3 convulational layers added gives me an accuracy of 70%

Now I am working on my blog. Stay tuned :v:t2:

2 Likes

Here is my assignment 3, achieving over 50% accuracy in the end, with only 4 hidden layers

1 Like

Hello everyone, I am working on the titanic data from kaggle competition, can any one suggest me how can I increase the accuracy further, I am currently at 0.84

Yes Vijay, you are absolutely correct. I should’ve been more alert since my validation accuracy and testing accuracy were the same. :sweat_smile:

2 Likes

Check your notebooks (versions) . The code is not getting reflected in the cells.

Yeah, I was almost thinking that even 80-ish% w/o any convolution layers is insane! Thanks for the clarification.

1 Like

Hi everyone,

i fixed my notebook so I can share it with you again!

I used a 4 layer model and achieved a 60% accuracy on the test dataset. I have also modified the CIFAR10Model class using a nn.ModuleList, so the different layers are now a list and can be created dynamically by passing a list with the desired lengths when initializing the class (_init_ method).

Cheers all,

Aris

1 Like

I FINALLY GOT 50% YAY

1 Like

Just make sure Internet is turned on. Open the sidebar by clicking the button on the top right, then turn on Internet.

Hi All,

Link to my notebook HERE.

Here are my versions and parameters I tried so far. 57.45 % is the maximum I achieved.

.

I will write this on another dataset and write a blog on that in the next 5 days.

Regards
Shravan

1 Like

here is link to my work, I could get 50% at the highest.
I tried Relu and Sigmoid functions for the forward. Relu got to this percent in less epochs than Sigmoid. Would try more data sets on when to use Relu and when to use sigmoid.

Looks like notebook is not complete

I can’t see the loss ac accuracy at each loss functions, looks like you forget to run that cell

Better, how many combination of layer did you tried before this. I am not able to cross even 54.